This page includes no more, no less than what you should have on your linux box to run properly...
plus SDL_Image library SDL_Net
I would choose 1.6.xx but 1.8 would be fine
paraguionly the 1.0.4.....